Discussion:
[PATCH] audit: Rename audit mark variable to amark
(too old to reply)
Jan Kara
2018-10-04 07:07:55 UTC
Permalink
Variable of audit_tree_mark type was called 'mark' which is confusing as
we usually call fsnotify_mark variables this way. Rename it to 'amark'
to make it explicit this a actually a different thing.

Signed-off-by: Jan Kara <***@suse.cz>
---
kernel/audit_tree.c | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)

Hello Paul,

here is the patch to rename mark to amark as Richard suggested.

Honza

diff --git a/kernel/audit_tree.c b/kernel/audit_tree.c
index 9c53f7c37bdf..232b8b18cb5b 100644
--- a/kernel/audit_tree.c
+++ b/kernel/audit_tree.c
@@ -175,14 +175,14 @@ static void audit_tree_destroy_watch(struct fsnotify_mark *mark)

static struct fsnotify_mark *alloc_mark(void)
{
- struct audit_tree_mark *mark;
+ struct audit_tree_mark *amark;

- mark = kmem_cache_zalloc(audit_tree_mark_cachep, GFP_KERNEL);
- if (!mark)
+ amark = kmem_cache_zalloc(audit_tree_mark_cachep, GFP_KERNEL);
+ if (!amark)
return NULL;
- fsnotify_init_mark(&mark->mark, audit_tree_group);
- mark->mark.mask = FS_IN_IGNORED;
- return &mark->mark;
+ fsnotify_init_mark(&amark->mark, audit_tree_group);
+ amark->mark.mask = FS_IN_IGNORED;
+ return &amark->mark;
}

static struct audit_chunk *alloc_chunk(int count)
--
2.16.4
Paul Moore
2018-10-04 14:23:48 UTC
Permalink
Post by Jan Kara
Variable of audit_tree_mark type was called 'mark' which is confusing as
we usually call fsnotify_mark variables this way. Rename it to 'amark'
to make it explicit this a actually a different thing.
---
kernel/audit_tree.c | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)
Hello Paul,
here is the patch to rename mark to amark as Richard suggested.
Thanks, merged into audit/working-fsnotify_fixes.
Post by Jan Kara
diff --git a/kernel/audit_tree.c b/kernel/audit_tree.c
index 9c53f7c37bdf..232b8b18cb5b 100644
--- a/kernel/audit_tree.c
+++ b/kernel/audit_tree.c
@@ -175,14 +175,14 @@ static void audit_tree_destroy_watch(struct fsnotify_mark *mark)
static struct fsnotify_mark *alloc_mark(void)
{
- struct audit_tree_mark *mark;
+ struct audit_tree_mark *amark;
- mark = kmem_cache_zalloc(audit_tree_mark_cachep, GFP_KERNEL);
- if (!mark)
+ amark = kmem_cache_zalloc(audit_tree_mark_cachep, GFP_KERNEL);
+ if (!amark)
return NULL;
- fsnotify_init_mark(&mark->mark, audit_tree_group);
- mark->mark.mask = FS_IN_IGNORED;
- return &mark->mark;
+ fsnotify_init_mark(&amark->mark, audit_tree_group);
+ amark->mark.mask = FS_IN_IGNORED;
+ return &amark->mark;
}
static struct audit_chunk *alloc_chunk(int count)
--
2.16.4
--
paul moore
www.paul-moore.com
Richard Guy Briggs
2018-10-10 12:27:23 UTC
Permalink
Post by Jan Kara
Variable of audit_tree_mark type was called 'mark' which is confusing as
we usually call fsnotify_mark variables this way. Rename it to 'amark'
to make it explicit this a actually a different thing.
Better late than never? I've been offline since Thursday. Looks good
to me.
Post by Jan Kara
---
kernel/audit_tree.c | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)
Hello Paul,
here is the patch to rename mark to amark as Richard suggested.
Honza
diff --git a/kernel/audit_tree.c b/kernel/audit_tree.c
index 9c53f7c37bdf..232b8b18cb5b 100644
--- a/kernel/audit_tree.c
+++ b/kernel/audit_tree.c
@@ -175,14 +175,14 @@ static void audit_tree_destroy_watch(struct fsnotify_mark *mark)
static struct fsnotify_mark *alloc_mark(void)
{
- struct audit_tree_mark *mark;
+ struct audit_tree_mark *amark;
- mark = kmem_cache_zalloc(audit_tree_mark_cachep, GFP_KERNEL);
- if (!mark)
+ amark = kmem_cache_zalloc(audit_tree_mark_cachep, GFP_KERNEL);
+ if (!amark)
return NULL;
- fsnotify_init_mark(&mark->mark, audit_tree_group);
- mark->mark.mask = FS_IN_IGNORED;
- return &mark->mark;
+ fsnotify_init_mark(&amark->mark, audit_tree_group);
+ amark->mark.mask = FS_IN_IGNORED;
+ return &amark->mark;
}
static struct audit_chunk *alloc_chunk(int count)
--
2.16.4
- RGB

--
Richard Guy Briggs <***@redhat.com>
Sr. S/W Engineer, Kernel Security, Base Operating Systems
Remote, Ottawa, Red Hat Canada
IRC: rgb, SunRaycer
Voice: +1.647.777.2635, Internal: (81) 32635

Loading...